[Networkit] pip installation failures

Christian Staudt christian.staudt at kit.edu
Mon Oct 20 09:39:48 CEST 2014


I’ve received the following error reports of a user who tried to install NetworKit via pip. The user tried it on OS X Mavericks and OS X Yosemite, and he said he has installed Cython, GCC 4.9 and SCons.

In the first case, compilation works at first but goes off the rails when compiling the Cython-generated source:

>   networkit/_NetworKit.cpp: At global scope:
>     networkit/_NetworKit.cpp:14630:12: warning: 'int __pyx_pw_10_NetworKit_9Partition_1__cinit__(PyObject*, PyObject*, PyObject*)' defined but not used [-Wunused-function]
>      static int __pyx_pw_10_NetworKit_9Partition_1__cinit__(PyObject *__pyx_v_self, PyObject *__pyx_args, PyObject *__pyx_kwds) {
>                 ^
>     networkit/_NetworKit.cpp:14811:18: warning: 'PyObject* __pyx_pw_10_NetworKit_9Partition_5__getitem__(PyObject*, PyObject*)' defined but not used [-Wunused-function]
>      static PyObject *__pyx_pw_10_NetworKit_9Partition_5__getitem__(PyObject *__pyx_v_self, PyObject *__pyx_v_e) {
>                       ^
>     /var/tmp//cc1BFqqV.s:18:bad register name `%rdi)’
>     /var/tmp//cc1BFqqV.s:38:bad register name `%rsi’

...and so on. Here is the full output: https://gist.github.com/anonymous/67b16f1afc738177a32f

@Michael: Could this be an issue with Cython versions?


In the second case, a Python error happens:

> Last login: Sun Oct 19 14:40:25 on ttys000
> Kuan-Weis-MacBook-Air:~ kimozy$ sudo pip3 install networkit
> Downloading/unpacking networkit
>   Downloading networkit-3.3.tar.gz (258kB): 258kB downloaded
>   Running setup.py (path:/private/tmp/pip_build_root/networkit/setup.py) egg_info for package networkit
> Installing collected packages: networkit
>   Running setup.py install for networkit
>     Traceback (most recent call last):
>       File "/usr/local/bin/scons", line 97, in <module>
>         import pkg_resources
>       File "build/bdist.macosx-10.9-intel/egg/pkg_resources.py", line 718, in <module>
>         unspecified, it defaults to the current platform.  `python` is an
>       File "build/bdist.macosx-10.9-intel/egg/pkg_resources.py", line 721, in Environment
>   

Full output: https://gist.github.com/anonymous/65518f51cbb6dcff1da4

Any ideas on this?

Christian 

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 495 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <https://lists.ira.uni-karlsruhe.de/mailman/private/networkit/attachments/20141020/76c85f4b/attachment.sig>


More information about the NetworKit mailing list