[Networkit] pip install fails with "cannot import name DEVNULL"

Christian Staudt christian.staudt at kit.edu
Fri Feb 20 10:08:50 CET 2015


On 20 Feb 2015, at 03:15, Ian <ian.wood at anu.edu.au> wrote:

> OK, it's proving difficult to install with pip (as opposed to pip3, which I've not tried yet - will it be available to python 2.7 if I install with pip3??)

Hi Ian,
it seems like you are trying to install networkit for Python 2.x. However, Python 3.x is required. Support for Python 2 is not something we have currently planned, frankly I do not see the point in backporting. So what are your reasons for wanting to stick with Python 2 rather than upgrading?

Best,
Chris

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ira.uni-karlsruhe.de/mailman/private/networkit/attachments/20150220/23bff0c0/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 495 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <https://lists.ira.uni-karlsruhe.de/mailman/private/networkit/attachments/20150220/23bff0c0/attachment.sig>


More information about the NetworKit mailing list