[Networkit] Checking for Python version during installation

Christian Staudt christian.staudt at kit.edu
Wed Mar 18 11:53:08 CET 2015


If a user tries to install NetworKit with the wrong Python version, it looks like this:
	https://stackoverflow.com/questions/29004223/pip-install-networkit-error

Can we make this more obvious by checking for the right version of Python first? sys.version gives that information, but I’m not sure at which point in the setup script this should be checked.

Chris
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 495 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <https://lists.ira.uni-karlsruhe.de/mailman/private/networkit/attachments/20150318/9bb5219c/attachment.sig>


More information about the NetworKit mailing list