[Networkit] Hi, I am interested in your program-networkit, but cannot run

Christian Staudt christian.staudt at kit.edu
Fri Mar 25 13:19:19 CET 2016


> On 25 Mar 2016, at 03:44, Ginseng <yongh701 at qq.com> wrote:
> 
> Thank you for releasing program on https://networkit.iti.kit.edu/
> but your program require python 3.x and cython,
> did you have other version programming in python 2.x or other programming-language---such as Java or C++.
> Because our country did not tend to use python 3.x.
> I am form China, I am interested in your program-networkit, I am interested in your NETWORKIT project and seek for your help.
> Thank you for your attention.



Hi,
it is possible to use only the C++ part of NetworKit as a library and build your own executable on it (as described here [1]), though I do not recommend this for general use cases. Perhaps it is best to transgress national customs and actually switch to Python 3.

Best,
Chris

[1]: https://networkit.iti.kit.edu/getting-started/


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 495 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <https://lists.ira.uni-karlsruhe.de/mailman/private/networkit/attachments/20160325/d4cefb07/attachment.sig>


More information about the NetworKit mailing list