[Networkit] about installing NetworKit

Matteo Riondato matteo at cs.brown.edu
Wed Jul 19 14:54:13 CEST 2017


> On Jul 19, 2017, at 7:29 AM, Kolja Esders <kolja.esders at student.kit.edu> wrote:
> 
> One thing to look at is the tkinter package that is required and can be installed with sudo apt-get install python-tk. This would also be noted in the error message though

tkinter is not listed as a requirement on https://networkit.iti.kit.edu/get_started.html .

Perhaps the project should consider using pip requirements files (see https://pip.pypa.io/en/stable/user_guide/#requirements-files).

Matteo

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ira.uni-karlsruhe.de/pipermail/networkit/attachments/20170719/7db1297f/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: Message signed with OpenPGP
URL: <http://lists.ira.uni-karlsruhe.de/pipermail/networkit/attachments/20170719/7db1297f/attachment.sig>


More information about the NetworKit mailing list