[palladio-dev] Problem with PCM metamodels v5

Chris Vogel chris_vogel at gmx.net
Fri Mar 16 11:44:59 CET 2012


Hi together,

I have a strange problem with Eclipse 3.7.2 ModelingTools with Operational  
QVT and the latest PCM 3.3 nightly build.
To use them in my QVT-O transformation I defined the PCM metamodels in the  
transformation header (see. qvt_models_pcm.png).
By using the new metamodels with version 5 I got the errors shown in the  
picture: Failed to resolve Metamodel "..." . When I use an old URL, like  
*/Repository/4.0 then you can see in the tooltip of Eclipse that it  
targets Version 5.0 of the PCM (see target_old_url.png)

Additionally in the View "Metamodel Explorer" I got some errors concerning  
the PCM metamodels as shown in picture metamodel_explorer_error.png
The ErrorLog has no entries concerning this.

Does anybody know what is wrong here? It seems that there at some point of  
the PCM still the old URLs are used...

Kind regards
Chris Vogel
-------------- next part --------------
A non-text attachment was scrubbed...
Name: metamodel_explorer_error.png
Type: image/png
Size: 30551 bytes
Desc: not available
URL: <http://lists.ira.uni-karlsruhe.de/pipermail/palladio-dev/attachments/20120316/ce1282ba/attachment-0003.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: qvt_models_pcm.png
Type: image/png
Size: 48683 bytes
Desc: not available
URL: <http://lists.ira.uni-karlsruhe.de/pipermail/palladio-dev/attachments/20120316/ce1282ba/attachment-0004.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: target_old_url.png
Type: image/png
Size: 10101 bytes
Desc: not available
URL: <http://lists.ira.uni-karlsruhe.de/pipermail/palladio-dev/attachments/20120316/ce1282ba/attachment-0005.png>


More information about the palladio-dev mailing list